现在的位置: 首页 > 编程·网络 > java编程 > 正文
在eclipse indgo中集成Drools5.5
2015年03月13日 java编程 ⁄ 共 951字 在eclipse indgo中集成Drools5.5已关闭评论 ⁄ 被围观 2,473 views+

1.1.前提条件

Drools是一款基于Java的开源规则引擎,所以在使用Drools之前需要在开发机器上安装好JDK环境,Drools5.5要求的JDK版本要在1.5或以上。

1.2.开发环境搭建

大多数软件学习的第一步就是搭建这个软件的开发环境,Drools也不例外。本小节的内容就是介绍如何搭建一个Drools5的开发、运行、调试环境。

首先,通过以下地址下drools 5.5.0Final版本,下载图中红色边框内两个zip包。http://download.jboss.org/drools/release/5.5.0.Final/

20140809000007563

1.3. 安装Drools IDE

打开Eclipse3.7所在目录下的dropins目录,在此目录下依次逐级建立drools文件夹和eclipse文件夹,如下图所示:

20140809000030355

将droolsjbpm-tools-distribution-5.5.0.Final.zip文件解压后进入到droolsjbpm-tools-distribution-5.5.0.Final\binaries\org.drools.updatesite目录中,将features文件夹和plugins文件夹拷贝到eclipse安装目录/dropins/drools/eclipse/目录下,如下图所示:

20140808235838125

此时便将drools5.5所有的插件文件安装到eclipse中,接下来要在win dos下重启Eclipse 3.7,检验Drools5.5是否安装成功。

设置eclipse启动时属性,如下图所示:

20140808235954968

依次打开WindowàPreferences,当显示如下图所示时,Drools5.5安装成功;

20140809000014359

IDE安装完成后,接下来需要对Drools5.5的IDE环境进行简单的配置,依次打开Window—> references,在弹出的窗口当中选择左边导航树菜单Drools寐Installed DroolsRuntimes设置Drools5.5 IDE运行时依赖的开发工具包,点击“Add…”按钮添加一个开发工具包,Path设置为drools-distribution-5.5.0.Final\binaries,如下图所示。

20140809000313313

点击“OK”后提示重新启动eclipse。

20140809000031046

重启完,新建工程时显示如下界面:

20140809000331923

打开Drools视图如下所示:

20140809000140218



本文链接:在eclipse indgo中集成Drools5.5

转载声明:本站文章若无特别说明,皆为原创,转载请注明来源:海鹏的博客,谢谢!^^


抱歉!评论已关闭.

无觅相关文章插件,快速提升流量